top button
Flag Notify
    Connect to us
      Facebook Login
      Site Registration Why to Join

Facebook Login
Site Registration

CentOS6.4 and Apple keyboard

+1 vote
162 views

I have just installed (with kikstart) centOS6.4 on a PC which was previously running OpenSUSE (11.x). This PC has an apple keyboard and I'm unable to setup this keyboard. In .xsession-errors I get this messages :

Error: No Symbols named "latin9" in the include file "macintosh_vndr/fr"
 Exiting
 Abandoning symbols file "(null)"

** (gnome-settings-daemon:8160): WARNING **: Could not activate the XKB  configuration
Error: No Symbols named "latin9" in the include file "macintosh_vndr/fr"
 Exiting
 Abandoning symbols file "(null)"

** (gnome-settings-daemon:8160): WARNING **: Could not activate the XKB configuration

Google found on a RedHat forum that it seams to be an old known bug but do not find any update or workaround. I've several PC using Apple keyboards as users have also Apple laptops and they do not want to work with two different keyboards.

posted Oct 10, 2013 by Anderson

Looking for an answer?  Promote on:
Facebook Share Button Twitter Share Button LinkedIn Share Button
What do you have in these files?
  /etc/sysconfig/keyboard
  /etc/X11/xorg.conf
  /etc/X11/xorg.conf.d/*

Maybe retry system-setup-keyboard?
It was the idea this morning: restart with a fresh install and a  standard pc keyboard and switch to the apple one after. But when selecting the apple keyboard in system-setup-keyboard menu I get:

Error activating XKB configuration.
It can happen under various circumstances:
- a bug in libxklavier library
- a bug in X server (xkbcomp, xmodmap utilities)
- X server with incompatible libxkbfile implementation

X server version data:
CentOS
11300000

So it is possible to work on the PC with the standard PC keyboard  but still not possible to use the apple keyboard.

Similar Questions
+1 vote

I would like to install cyrus-imapd 2.4 in CentOS6. I have found rpm cyrus 2.4 for CentOS6 on rpmseek.
cyrus-imapd-2.4.17-30.1.x86_64.rpm

But there are conflicts with postfix 2.6.6. Can I ignore this conflicts or is there a suitable version of ppstfix available?

+10 votes

In Cent-OS, If i press any special character from my keyboard it is giving some other character output display. Which i have not intended/pressed.
For example, If i press @ from keyboard the actual display character in output i am getting is "
Reversal is also same. It is happening with all special characters on keyboard. Help me out for this.

0 votes

On CentOS5 I was used to create a simple spec file where at the end I'll declare files and directories I wan't to package:

%files
%dir /opt/myapp
%dir /opt/myapp/bin
%dir /opt/myapp/etc
/opt/myapp/bin/exec01
/opt/myapp/etc/myapp.conf

I'll copy the file in /usr/src/redhat/SPECS and run "rpmbuild -bb myapp.spec".

On CentOS6 rpm-build package no longer creates the /usr/src/redhat/... directory tree. I followed the CentOS6 Wiki instructions to setup my rpmbuild environment for a regular user.

When I try to build the package on CentOS6 I'm getting this error for every single file and directory:

File not found:

/home/myhome/rpmbuild/BUILDROOT/myapp-5.2-1el6.x86_64/opt/myapp/bin/exec01

I tried to override buildroot:

rpmbuild -bb --define="buildroot /" myapp.spec
 error: %{buildroot} can not be "/"

As a workaround I can manually create /home/myhome/rpmbuild/BUILDROOT/myapp-5.2-1el6.x86_64/ and copy all my file in there but that's a lot of extra work.

Is there a way to get the same functionality on CentOS6 where rpmbuild will collect the files from the main / directory and build the rpm package?

Contact Us
+91 9880187415
sales@queryhome.net
support@queryhome.net
#280, 3rd floor, 5th Main
6th Sector, HSR Layout
Bangalore-560102
Karnataka INDIA.
QUERY HOME
...