top button
Flag Notify
    Connect to us
      Facebook Login
      Site Registration Why to Join

Facebook Login
Site Registration

Apache Error: Options ExecCGI is off in this directory

0 votes
1,032 views

with my python script running, but I always get a 403-Error. And apache logfile says:

Options ExecCGI is off in this directory:/home/user12/cgi-bin/showblogs.py

apache configuration:

AllowOverride None
AddType application/python .py
DirectoryIndex index.html index.htm index.php index.py
Options +ExecCGI Indexes FollowSymLinks MultiViews
AddHandler cgi-script .cgi .pl .py
AllowOverride All
Order allow,deny
allow from all

So what is missing or wrong here?

posted Aug 16, 2013 by Bob Wise

Share this question
Facebook Share Button Twitter Share Button LinkedIn Share Button

1 Answer

+1 vote

If it's the 2.4 must change "allow from all" to "Require all granted".

answer Aug 16, 2013 by anonymous
Similar Questions
0 votes

I want to allow a directory " /var/www/html/ldap" to two users according to IPs (192.168.1.2 192.168.1.7):

 Order allow,deny
 Allow from 192.168.1.2 192.168.1.7
 Satisfy any
 AuthName "LDAP Authentication"
 AuthType Basic

 AuthBasicProvider ldap
 AuthzLDAPauthoritative off
 AuthLDAPURL ldap://192.168.1.3/dc=example,dc=com?uid?sub?(objectClass=*)
 Require valid-user

but I don't want to allow a sub directory to 192.168.1.7 (I want it to be allowed only to 192.168.1.2):

I have tried to add:

 Order allow,deny
 Allow from 192.168.1.2
 Satisfy any
 AuthName "LDAP Authentication"
 AuthType Basic

 AuthBasicProvider ldap
 AuthzLDAPauthoritative off
 AuthLDAPURL ldap://192.168.1.3/dc=example,dc=com?uid?sub?(objectClass=*)
 Require valid-user

but it seems that 192.168.1.7 can reach to manager directory because it is a part of ldap directory, how can I forbid this?

+1 vote

Apache/Tomcat (by default) does not allow symbolic linking (nice as it can cross mounted file systems) except in the top apache/lib directory. I use hard links in the Application/WEB-INF/lib directories to reduce copying and help me manage things.

HOWEVER, some applications have special needs - e.g. pictures. You don't want to always distribute these with the release of the application (Application.war file), so symbolic links are the way to go (except for MS land, sorry). The nice solution to this is:

.../webapps/Application/WEB-INF/context.xml
which must contain at least the two below lines:

However this allows ALL symbolic linking in the Application directory. I agree with the developers that this is dangerous.

Is there some way to allow linking in just ONE sub-directory of the Application?
- e.g. .../webapps/Application/images

This would allow all I need to have local images for the application without endangering other things using a symbolic link.

+2 votes

I want the images should be accessible as part of http page only not by any other mean, no clue any suggestion would have great help.

+1 vote

I am working on a Ubuntu 10.04 server, on which I installed PHP 5.3, Apache 2 2.2.9. I followed the below steps to do the installation :

  1. I installed apache2 using SUDO APT-GET INSTALL APACHE2

  2. I also installed libapache2 and php using the below commands
    sudo apt-get install php5 libapache2-mod-php5
    sudo apt-get install php5-core

  3. I did redirection to port by configuring the DEFAULT file in /ETC/APACHE2/SITES-AVAILABLE. Redirection happened successfully.

  4. PHP5-curl was installed using
    SUDO APT-GET INSTALL PHP5-CURL

  5. Rewrite mod was enabled in apache2 using
    SUDO A2ENMOD REWRITE and apache2 was restarted.

Now, after following this if I try to access the URL, I get the following message -

 THE REQUESTED URL /.../..../ WAS NOT FOUND ON THIS SERVER.  

But, the same URL is accessed from another system with the same configuration , it works fine.

+2 votes

I have apache server in my local network installed from apt-get install apache2, but my php version is old version and I divided to make compile the apache and add php5.4 module.I want compile this apache from source code httpd-2.4.10 version, my ./configure this:

./configure --prefix=/usr/local/apache2  --enable-so --sysconfdir=/etc/httpd/conf

this work for default apache webserver, but my vhosts don't work, they are status 403 "dont forbidden access".
not want to do different from apache in apt-get install, but I want apache and PHP lasts releases from my server.

How to make vhosts config in apache compiled from source code httpd-2.4.10, i need resolve this "problem" for my environment.

Contact Us
+91 9880187415
sales@queryhome.net
support@queryhome.net
#280, 3rd floor, 5th Main
6th Sector, HSR Layout
Bangalore-560102
Karnataka INDIA.
QUERY HOME
...