top button
Flag Notify
    Connect to us
      Facebook Login
      Site Registration

Facebook Login
Site Registration

Apache: error mod_ssl requires OpenSSL 0.9.8a or later?

+2 votes
362 views

I am trying to compile httpd-2.4.7 from source, but i get the following error

"#error mod_ssl requires OpenSSL 0.9.8a or later"

But my installed openssl version is openssl-1.0.1e and I have specified it --with-ssl option.
Any suggestions?

posted Dec 16, 2013 by Kumar Mitrasen

Looking for an answer?  Promote on:
Facebook Share Button Twitter Share Button LinkedIn Share Button
First make sure openssl-devel-1.0.1e is installed. --with-ssl=

Example: --with-ssl=/usr/include/openssl

Where can I get openssl-devel? openssl.org only shows openssl-*, openssl-engine-* and openssl-fips-*
Try
apt-get install libssl-dev
or
yum install openssl-devel*
Sorry, forgot to mention that I am compiling on AIX.
But the problem was not in openssl, but rather in a typo I made on the configure commandline, omitting one of the dashes.
Would be nice if the configure script complained about -with-ssl (instead of the correct --with-ssl), or any other erroneous option
Can you please ask a fresh question, as it is confusing to ask question with other question chain (probably register and ask it improves the chances of response)

Similar Questions
+1 vote

My custom openssl engine works fine, tested it many times. I wanted to test it using mod_ssl, but needed a patch to enable dynamic engine support.
Now the problem is, I get a segmentation fault, whenever rsa methods in my custom openssl engine is called. I am using apache 2.4, and openssl 0.9.8e. Has anyone experienced it before?

+1 vote

We have Apache 2.2.22 (Win32) on a Windows 2008 64 bit server. It currently has OpenSSL 0.9.8.

We are trying to apply the OpenSSL 1.0.1h on the same, after applying the open SSL and copying the relevant files to the bin directory of apache server, we are not able to start the server. It gives an mod_sso error.

Any Suggestions?

+1 vote

I need to enable TLS 1.2 but since I currently have Apache 2.2.25 w/OpenSSL 0.9.8 installed, I can't do that. So, I left Apache 2.2.25 in place, installed OpenSSL 1.0.2a, and created the new openssl.cnf environment variables. The install was successful, the correct version is showing, but TLS 1.2 is still not enabled.

Any ideas on what I am missing?

+1 vote

I'm working on doing some upgrade testing to mitigate the Heartbleed issue and some other vulnerabilities. Part of that is updating OpenSSL, but I'm a bit confused about something and am hoping that someone can help me. I've done at least a dozen internet searches and can't find the answer. It's probably simple, but I'd like to find out anyway.

What do I need to do in order to update the version of OpenSSL that is included in the Apache HTTP server release? I've installed OpenSSL 1.0.1g on the server, but the older version is still in the apache /bin directory. Do I simply replace the openssl executable or is there some kind of change that needs to be made in the httpd.conf file to point to the newer installation?

0 votes

I am trying to refresh our web site with the latest version of apache. As part of the refresh I want to enforce SSL access to the site. I've setup SSL and the site mostly works with basic authentication, but I have errors when trying to download/view video files from the web site.

I've tried several different clients and 80% of the time I get a window with a big square and if one clicks on the square it says "The specified movie could not be found". Sometime firefox on a Mac will actually play the movie but mostly not.

I can retrieve the movie using wget just fine.

In the error log a debug trace shows it making one request for the web page and the authentication for that suceeds, but then the second request for the video file is rejected because the credentials are not available! Is there an option which tells the client not to send the authentication information? or to clear when requesting?

AH01626: authorization result of Require group svsaccess: granted,
AH01626: authorization result of Require group svsaccess: denied (no authenticated user yet)

BTW, the site works as expected under non-SSL connections.

Contact Us
+91 9880187415
sales@queryhome.net
support@queryhome.net
#280, 3rd floor, 5th Main
6th Sector, HSR Layout
Bangalore-560102
Karnataka INDIA.
QUERY HOME
...