top button
Flag Notify
    Connect to us
      Facebook Login
      Site Registration Why to Join

Facebook Login
Site Registration

Android: Are there any usage limits on LocationManager.NETWORK_PROVIDER?

+2 votes
118 views

Are there any usage limits on LocationManager.NETWORK_PROVIDER?For example, is there a limit on the number of uses per day, or is limited to personal use.

LocationManager.NETWORK_PROVIDER http://developer.android.com/reference/android/location/LocationManager.html#NETWORK_PROVIDER

I find the LocationManager.NETWORK_PROVIDER and The Google Maps Geolocation API very similar.(It is possible to know the position information from the cell tower or wifi both.)

The Google Maps Geolocation API https://developers.google.com/maps/documentation/business/geolocation/

The Google Maps Geolocation API has usage limits and costs money, are there any usage limits like these on LocationManager.NETWORK_PROVIDER?

posted Nov 12, 2013 by Sheetal Chauhan

Share this question
Facebook Share Button Twitter Share Button Google+ Share Button LinkedIn Share Button Multiple Social Share Button

1 Answer

+1 vote

No, there is no limit in LocationManager.NETWORK_PROVIDER.

answer Nov 12, 2013 by Majula Joshi
Thanks what could be the reason,
Because it's an Android's standard API which provides you the location results based on availability of cell tower and WiFi access points. Also Results are retrieved by means of a network lookup, (Here Google isn't providing any proprietary service to you)
Whereas Google Maps Geolocation API provides you the results as a Google service (free limited usage).
Similar Questions
+7 votes

I am trying to get google-geo to work, but I am seeing errors.

#!/usr/bin/ruby

require 'Google-geo'

mykey = 'blahblahblah'
addy1 = 'xxxxxxxxxxxxx' # xx, yy

geo = Google::Geo.new mykey
res = geo.locate addy1
puts res.coordinates

...and the error:

/Library/Ruby/Site/2.0.0/rubygems/core_ext/kernel_require.rb:55:in require': cannot load such file -- Google-geo (LoadError) from /Library/Ruby/Site/2.0.0/rubygems/core_ext/kernel_require.rb:55:inrequire'
from pdev.rb:6:in `'

Not sure why it can't load it as it's just installed. I can't get anything to work in irb either.

+2 votes

Which latest method has been introduced in 3GPP specification to find out more precise location of the UE ?

+3 votes

We are planning to add an android app, but need some help on GCM. Does anyone have any good pointer to implement GCM if so please suggest.

+3 votes

How can I convert the value of the speech rate value from Google's TTS into words per minute? Is there any direct relation between them, somewhere in the source code?

+4 votes

When I install and open an android application with my tablet I have an error message which same that my tablet is Rooted and it is not compatible with the Google certification.
I check my tablet with the app root checker and apparently my tablet is unroot. I thing it's not correctly or not complitly unroot but don't know how to have a correct unroot code. Can someone help me?

Contact Us
+91 9880187415
sales@queryhome.net
support@queryhome.net
#280, 3rd floor, 5th Main
6th Sector, HSR Layout
Bangalore-560102
Karnataka INDIA.
QUERY HOME
...